[MinnowBoard] Unable to Boot/Install pfSense

John Hawley john.hawley at intel.com
Wed Jul 13 21:48:44 UTC 2016


What version of firmware are you on?

So the problem boils down to the fact that what gets shipped is a pure
UEFI firmware, without any of the legacy BIOS compatibility layers.  The
memstick image that's provided looks like it's a single giant partition
with BSD in it.  This however isn't compatible with UEFI, as it's
expecting a specific partition to be around to kickstart the whole boot
process.

Some quick looks seems to indicate that pfSense doesn't (at least
currently) have UEFI support, though I know that FreeBSD works.  Not
100% sure how to get it past and installing, and I'd probably try a usb
cdrom drive but that's not exactly a great way to go.

You *COULD* try downloading the cd image, dding it to a usb stick and
see if that will actually boot (no guarantees but sometimes that works).
 I'll take a look into it and see what I can find though.

- John 'Warthog9' Hawley

On 07/13/2016 01:55 PM, Domenic DiPasquale wrote:
> Hello,
> 
> I've been trying to set up pfSense on this minnow max for a couple days
> now and haven't had much progress. I noticed on MinnowBoard's Google+
> account that others have had success setting up pfSense and was
> wondering if anyone would be able to help?
> 
> I've downloaded all my AMD64 (64-bit), CD Image Installer (.iso)/USB
> Memstick Installer (.img) from https://www.pfsense.org/download/ and
> tried various ways to make them into bootable USBs (unetbootin, linux's
> dd command, etc). Every time I tried making the .img a bootable USB, it
> becomes unaccessable from any computer and isn't recognized by the bios
> when I try to boot with it. When I made the .iso a bootable USB, I got
> no error and it was recognized by the bios. Although, I was unable to
> boot from the USB until I added a boot option to use the loader.efi,
> which finally booted pfSense. Unfortunately, I still get an error after
> the pfSense menu: 
> 
>>Mounting from cd9660:/dev/iso9660/PFSENSE failed with error 19.
>>
>>Loader variables:
>>    vfs.root.mountffrom=cd9660:/dev/iso9660/PFSENSE
>>    vfs.root.mountffrom.options=ro
>>
>>Manual root filesystem specification:
>>    <fstype>:<device> [options] 
>>        Mount <device> using filesystem <fstype>
>>                       
>>        eg. ufs:/dev/da0s1a
>>              zfs:tank
>>              cd9660:/dev/acd0 ro
>>                   (which is equivalent to: mount -t cd9660 -o ro
> /dev/acd0 /)
>>
>>    ?                          List valid disk boot devices
>>    .                           Yield 1 second (for background tasks)
>>    <empty line>       Abort manual input
>>
>>mountroot>
> 
> I've tried suggesting all of the devices returned from "?" at the
> mountroot> in every combination of ufs:/dev/ and cd9660:/dev/, I've
> tried adding a delay at the loader prompt after the pfSense menu:
> 
>>set kern.cam.boot_delay="10000" 
>>boot
> 
> Nothing seems to work and any help/advice would be appreciated, thank
> you in advance.
> 
> 
> _______________________________________________
> elinux-MinnowBoard mailing list
> elinux-MinnowBoard at lists.elinux.org
> http://lists.elinux.org/mailman/listinfo/elinux-minnowboard
> 


More information about the elinux-MinnowBoard mailing list