[MinnowBoard] Unable to Boot/Install pfSense

Domenic DiPasquale domenic at providiusdesign.com
Wed Jul 13 20:55:02 UTC 2016


Hello,

I've been trying to set up pfSense on this minnow max for a couple days now
and haven't had much progress. I noticed on MinnowBoard's Google+ account
that others have had success setting up pfSense and was wondering if anyone
would be able to help?

I've downloaded all my AMD64 (64-bit), CD Image Installer (.iso)/USB
Memstick Installer (.img) from https://www.pfsense.org/download/ and tried
various ways to make them into bootable USBs (unetbootin, linux's dd
command, etc). Every time I tried making the .img a bootable USB, it
becomes unaccessable from any computer and isn't recognized by the bios
when I try to boot with it. When I made the .iso a bootable USB, I got no
error and it was recognized by the bios. Although, I was unable to boot
from the USB until I added a boot option to use the loader.efi, which
finally booted pfSense. Unfortunately, I still get an error after the
pfSense menu:

>Mounting from cd9660:/dev/iso9660/PFSENSE failed with error 19.
>
>Loader variables:
>    vfs.root.mountffrom=cd9660:/dev/iso9660/PFSENSE
>    vfs.root.mountffrom.options=ro
>
>Manual root filesystem specification:
>    <fstype>:<device> [options]
>        Mount <device> using filesystem <fstype>
>
>        eg. ufs:/dev/da0s1a
>              zfs:tank
>              cd9660:/dev/acd0 ro
>                   (which is equivalent to: mount -t cd9660 -o ro
/dev/acd0 /)
>
>    ?                          List valid disk boot devices
>    .                           Yield 1 second (for background tasks)
>    <empty line>       Abort manual input
>
>mountroot>

I've tried suggesting all of the devices returned from "?" at the
mountroot> in every combination of ufs:/dev/ and cd9660:/dev/, I've tried
adding a delay at the loader prompt after the pfSense menu:

>set kern.cam.boot_delay="10000"
>boot

Nothing seems to work and any help/advice would be appreciated, thank you
in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.elinux.org/pipermail/elinux-minnowboard/attachments/20160713/ae9c45f4/attachment.html>


More information about the elinux-MinnowBoard mailing list